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1. Introduccién

Cuando se trata de comunicar un resultado cientifico es imprescindible elaborar un informe adecua-
do. En el mundo académico los trabajos cientificos se elaboran bajo un estandar comun el cual libera al
autor de la tarea de edicion del articulo o paper. La misma es resuelta autométicamente por un sistema
de reglas estandar que definen al articulo o publicacién. Este conjunto de reglas de tipografia se conoce
como el sistema tipografico TEX, creado por Donald Knuth en 1978. El mismo ha sido implementado
en muchos lenguajes de los cuales el mas famoso y utilizado en la academia es I&

De esta forma, utilizando el lenguaje A TEX podemos crear un documento pero el proceso es diferente
que en otros procesadores de texto mas comunes. El aspecto que tiene el documento mientras es escrito
suele verse muy distinto a la forma que tendréd una vez finalizado o compilado, ver figura . Existen
muchos editores de texto que facilitan la creacion de un documento en IXTEX, pero todos muestran
el codigo y suelen ser no tan amigables como los procesadores de texto usuales que muestran el
documento tal como se verd cuando se imprima. A este tipo de editores se los conoce con la sigla
en inglés WYSIWYG que abrevia “what you see is what you get” que significa “lo que ves es lo que
obtendras”.

LIATEX hace referencia al lenguaje utilizado para crear el documento, no para el editor de textos utilizado.



 ‘documentclass[l2pt] {article}
‘usepackage{amsmath}
‘title{\LaTeX}
\date(}
\begin{document)

‘maketitle

\LaTeX{} is a document preparation system for the \TeX{}
: typesetting program. It offers programmable desktop publishing
i features and extensive facilities for automating most aspects of
: typesetting and desktop publishing; including numbering and
: cross-referencing, tables and figures, page layout, bibliographies, ]
: and much more. \LaTeX{]} was originally written in 1984 by Leslie !
: Lamport and has become the dominant method for using \TeX; few 5
people write in plain \TeX{] anymore. The current version is ;
\LaTeXe.

low

i \begin{align}

i \end{document}

| E &= mc"2 A :
: m &= \frac{m 0} {\sgrt({l-\frac{v~2}{c"2}}] :
i \end{align] 5

ETEX is a document preparation system for the TEX typesetting pro-
gram. It offers programmable desktop publishing features and extensive fa-
cilities for antomating most aspects of typesetting and desktop publishing,
including numbering and cross-referencing, tables and figures, page layout,
bibliographies, and much more. IXI'gX was originally written in 1984 by
Leslie Lamport and has become the dominant method for using TEX; few
people write in plain TEX anymore. The current version is BTEX 2.

E = md? (1)
"= —— (2)

Figura 1.1: SUPERIOR: Aspecto usual de los editores de BTEX con los comando corresponeidntes y
texto del documento. INFERIOR: Documento compilado cuya fuente es el codigo en la figura superior.
FUENTE: http://en.wikipedia.org/wiki/LaTeX



http://en.wikipedia.org/wiki/LaTeX

La diferencia entre los procesadores de texto WYSIWYG (por ejemplo, Microsoft Word, OpenOffice
Writer, Abiword, etc) y los editores de lenguaje IATEX es que en los primeros el usuario debe preocuparse
del aspecto final del documento y debe invertir un cierto tiempo (a veces mayor al de redaccion) en
editar el mismo. La tarea de edicién del documento no es facil y suele ser una fuente de errores de
estilo y confeccién que degradan la calidad del documento, por ejemplo, falta de pié de figuras, titulos
y sub-titulos mal formateados, ecuaciones sin numerar, formulas confusamente escritas. En BTEX la
edicion del documento no corre por cuenta del usuario, si no que forma parte del estandar a partir
del cual el documento serd generado. El usuario inicamente debe escribir el documento e indicar la
estructura del mismo, el resto se hara solo.

ETEX es un lenguaje para escribir documentos con el sistema tipografico TEX desarrollado por Leslie
Lamport a principios de los 80’s y que se volvié el lenguaje dominante para la redaccién de articulos,
papers y libros por parte de mateméticos, fisicos, bibliotecologos, economistas e informéticos, entre
otros.

1.1. Ventajas de LyX

Este sofware resulta muy comodo para la elaboracion de documentos en INTEX ya que es un hibrido y
constituye un paso intermedio entre los procesadores de texto comunes y los editores IN\TEX avanzadoﬂ
El mismo permite que el usuario escriba el texto de manera muy simple y familiar, pero con ciertas
restricciones. Por ejemplo, el usuario no puede apretar muchas veces la tecla enter para dejar un
espacio en blanco en el documento, dado que ese aspecto ya esté definido. Las ventajas del uso de LyX
pueden ser resumidas en los siguientes puntos

= Interfaz amigable para el usuario inexperiente en la redacciéon de un documento IXTEX.
= [yX esta disponible para muchas plataformas y bajo la licencia GNU General Public License.
= Permite un rapido y facil mantenimiento y reciclaje de documentos previamente elaborados.

= Permite acceder al codigo IXTEX del documento y asi utilizarlo en otros editores W TEX asi como
también importar dicho cédigo como plantillas, etc.

1.2. Configuracién Previa

Previo a elaborar el documento es necesario configurar algunas cosas, como mérgenes del documen-
to, tipo de documento, hiper vinculos, barras de herramientas, etc. Lo haremos de la siguiente manera.
En el ment Document > Settings podemos configurar muchas opciones. Algunas como las que siguen

1. DocUMENT Crass: Podemos elegir article (opcion por defecto), book, curriculum vitae. Para la
elaboraciéon de informes basta con article

2. FonTs: Podemos elegir en Default Family las opciones de Roman, Sans Serif y Typewriter.
Teniendo aspectos diferentes segun se trate del documento. Roman luce como este documento
(como un libro), Sans Serif da una vista mas moderna y Typewriter da un aspecto de méaquina
de escribir.

3. PAGE MARGINS: Aqui podemos elegir el espacio entre el texto y los bordes de la hoja. Para un
aprovechamiento mayor de la hoja pueden ingresarse valores de 3cm para todos los margenes o
el usuario puede probar el mas adecuado para su documento.

4. PDF PROPERTIES: Aqui podemos habilitar el soporte de hiper vinculos (Use hyperref support).
De esta forma cuando nuestro documento sea leido en una computadora, el lector podra hacer
click en direcciones web en las figuras y secciones del documento mismo.

5. BULLETS: Aqui podemos definir el aspecto de las vifietas segtn el nivel

2IxX en si mismo define el slogan WYSIWYM sigla de “what you see is what you mean”, que significa “lo que ves es
lo que querés decir”



2.
2.1.

] EsTILO \ DESCRIPCION

standard Texto normal
title Titulo del trabajo
author Linea del autor del trabajo
date Linea de la fecha del trabajo
abstract Espacio para el abstract del trabajo
part Titulo para un capitulo
section Titulo para una seccion
subsection Titulo para una sub-secciéon
subsubsection Titulo para una sub-sub-seccién
lyx-code Texto en formato de codigo
itemize Formato de vineta
enumerate formato de vileta numerada

Cuadro 1: Algunos de los estilos que puede tener el texto en LyX.

Texto

Estilos del Texto

En IyX todo texto escrito dentro del documento tiene un atributo. Este atributo especifica qué
tipo de texto es, como por ejemplo, titulo del documento, titulo de una seccién, texto normal, texto de
abstract, texto de c6digo, texto de vineta, etc. Cada tipo distinto tiene un formato distinto de forma tal
que el titulo estara centrado y serd de un tamano grande, etc. Para esto debemos estar atentos siempre
a cual tipo hemos asignado al texto que escribimos. Lo mas cémodo es escribir el texto deseado, luego
seleccionar el mismo y dar el estilo adecuado en el selector de estilos. Se detalla una lista de tipos o
estilos en el cuadro ().

2.2,

2.3.

Resaltadores de Texto

Enrasts: Cuando queremos resaltar sutilmente el texto normal en Iy’X hay dos maneras. El
énfasis muestra el texto en modo #tdlico. El mismo puede indicar palabras en otro idioma, titulos
de libros o fuentes bibliograficas, nombres propios, etc. Esta opcion se activa con el botén Enfasis
de la barra estandar.

TEXTO CAPITAL: Cuando queremos resaltar ain mas el texto, podemos mostrar el mismo en
CARACTERES CAPITALES o mayusculas. Por ejemplo en titulos dentro de un pié de figura, en-
cabezados de columnas de una tabla de datos, etc.

FUENTE MONO-ESPACIADA: Cuando queremos indicar un comando de ejecucion de algun soft-
ware o simplemente escribir un parrafo con fuente mono-espaciada, podemos seleccionar el modo
de texto lyz-code en el selector de estilos. El mismo serd aplicado a todo el parrafo o linea aislada.

URL: Si queremos indicar una direccién web, o una direccién de algin archivo en una direccién
FTP o local, podemos utilizar la opcién de mostrar el texto como URL el cudl agregaré la opcién
de hacer click y seguir el linkﬂ a dicha direccién, por ejemplo http://www.ubuntu.org.uy. Para
hacer esto vamos al menu Insert > URL.

Titulo y Abstract

Los trabajos cientificos e informes deben tener un encabezado claro y conciso donde figuren el titulo,
los autores y sus respectivas filiaciones, la fecha del trabajo y el abstract. Este altimo es muy importante

3Es posible hacer click en el link si hemos habilitado el soporte de hipervinculos, ver seccién 1j


http://www.ubuntu.org.uy

va que describe en pocos renglones los resultados principales del trabajo sin entrar en detalles de tipo
experimental o consideraciones teéricas. El abstract debe resumir el trabajo y la importancia del mismo
enunciando los resultados finales generales obtenidos.

2.4. Etiquetas y Referencias

Las etiquetas es quiza una de las funciones mas ttiles de LyX y el entorno ETEX en general, ya que
nos permite asignar etiquetas o labels a los distintos objetos que vamos creando a lo largo del documento
como ser ecuaciones, figuras, tablas, secciones, etc. Las etiquetas son invisibles en el documento final
y simplemente se muestran en la pantalla de edicién del documento para que el usuario pueda verlas.
Para ingresar una etiqueta en una figura o tabla debemos hacerlo posicionando el cursor dentro del
pié de la misma y haciendo click en Insert > Label. Una vez creadas las etiquetas podemos hacer
referencia a ellas, por ejemplo en otra secciéon, de forma tal que LyX siempre asigne la correspondencia
correcta entre la referencia y el objeto etiquetado. Para hacer una referencia simplemente escribimos
“ver figura ()” y dentro del paréntesis ponemos el cursor y luego insertamos haciendo click en Insert >
Cross Reference y seleccionamos de la lista el objeto deseado. De esta forma Iy’X no perdera de vista
el objeto aunque sean eliminados objetos intermedios o sean insertado nuevos.

2.5. Indice

El indice generalmente se coloca en trabajos extensos como monografias y libros. El mismo puede
tener una utilidad adicional cuando se activa el soporte de hiper vinculos en el cual los items del
indice funcionaran como hiper vinculos dentro del propio documento PDF finalmente generaddﬂ Para
insertar la Tabla de Contenidos o Indice hacemos click en Insert > List / TOC > Table Of Contents.

3. Objetos Flotantes

3.1. Figuras

Las figuras o gréficas pueden ser insertadas en el documento de varias formas. La méas flexible es
insertarla como un objeto flotante en el mena Insert > Float > Figure. Luego se creara un marco en
el que directamente debe ingresarse el pié de figura con su descripcién, ver seccién . Con el cursor
dentro del cuadro pueden insertarse una o varias figuras en el ment Insert > Graphics. En el panel de
selecciéon del archivo también es posible seleccionar el tamano del grafico en unidades de porcentaje
con respecto al tamano original, se debe seleccionar el tamano adecuado probando con algunos valores.
Para que las imagenes queden centradas con el cursor podemos pintar la imagen en sentido horizontal
y seleccionar Center en la opcién Paragraph Settings. Un ejemplo de esto es la propia figura .

3.2. Tablas

El procedimiento de elaboracién de tablas es similar al descrito para insertar graficos en la seccién
(3-1). Lo hacemos en el menu Insert > Float > Table. Luego de ingresar el texto del pié de tabla y
la etiqueta correspondiente, con el cursor dentro del recuadro hacemos Insert > Float > Table. En
el recuadro siguiente ingresamos las dimensiones de la tabla que igualmente podran ser modificadas
luego. La primera fila de la tabla aparecera separada del resto para senalar la fila donde se escriben los
titulos de las columnas a mostrar. Podemos pintar la tabla con el mouse en sentido horizontal y con
click derecho en Paragraph Settings, nuevamente seleccionar el centrado correspondiente, por ejemplo
Center. Las opciones de tabla son variadas e incluyen desde tamafio y centrado hasta el delineado total
o parcial de las propias celdas de la tabla. Un ejemplo de esto es el cuadro o tabla .

4El documento PDF puede ser generado simplemente haciendo click en el botén rojo en la barra de herramientas
View/Update



4. FEcuaciones

Existen muchas formas de ingresar ecuaciones o entornos matematicos para mostrar una variedad
de cosas. Las modalidades basicas de las ecuaciones son tres, las ecuaciones que se expresan en la
misma linea de texto, las cuales sirven para indicar pequefias igualdades, como n =1 o v = 15km/p.
Las ecuaciones mas grandes y que requieren mas atenciéon deben ser colocadas en lineas aparte y las
mismas seran autométicamente centradas. Para cualquiera de ellas necesitamos los paneles de simbolos
activados llamados Math (auto) y Math Panels (auto). Para ver los paneles hay que seleccionarlos en
View > Toolbars.

4.1. Ecuaciones en el Texto

Se utilizan cuando queremos indicar pequenas igualdades o definiciones de constantes, como n = 1
o v = 15km/p. La forma de hacerlo es en el mena Insert > Math > Inline Formula. En el recuadro
podremos ingresar una variedad de simbolos matematicos y también los disponibles en el teclado.

4.2. FEcuaciones Numeradas

Las ecuaciones de mayor importancia deben ser mostradas en un entorno aparte del texto, para lo
cual luego de terminar el parrafo, hacemos click en Insert > Math > Numbered Formula, o utilizamos
el atajo con teclas (Ctrl4+Alt+N). Esto creard un recuadro en el que podremos ingresar la misma
variedad de simbolos matematicos, delimitadores para matrices, simbolos de sumatorias, integrales,
etc, como se ve en la ecuacion . La ecuacién tendra un nimero asociado y la misma generalmente
debera ir acompanada de su correspondiente etiqueta, ver secciéon . Las ecuaciones pueden incluir
algun texto pero el mismo debe ser cuidadosamente ingresado agregando espacios entre las palabras,
pues al tratarse de una ecuacién se omiten los espacios. Los mismos pueden ser ingresados con el
boton Math Spacings de la barra de funciones y permite varios tamanos de espacios. El usuario deberé
familiarizarse con el entorno matematico de LyX y la forma mas eficiente de ingresar los simbolos.
Para el caso de sumatorias, integrales y potencias es muy util el boton de Subscript y Superscript que
permiten escribir texto como limite inferior o superior o también potencia o subindice.

%f (2)dz = 2mi ZI (v,ax) Res (f, ax) (4.1)
R k=1

4.3. Ecuaciones No Numeradas

Analogamente a las ecuaciones numeradas, pero la diferencia es que la misma no tendra un nimero
asignado. Las mismas sirven para mostrar desarrollo operatorio o resultados intermedios que no seran
citados a lo largo del trabajo. Se inserta en el ment Insert > Math > Display Formula o con el atajo
(Ctrl+Shift+M).

5. Enlaces de Interés

= ITEX Project - http://www.latex-project.org/

= ITEX Wikipedia - http://en.wikipedia.org/wiki/LaTeX
= LyX Sitio Oficial - http://www.lyx.org/

» IyX en Wikipedia - http://en.wikipedia.org/wiki/LyX
= LyX Tutorials - http://wiki.lyx.org/LyX/Tutorials

= [y X Documentation - http://wiki.lyx.org/LyX/Documentation
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